SoftFashion

Join Polylines in AutoCAD


Sometimes when you import an AutoCAD DXF file into StyleCAD, an object's polylines are not joined. This means that each line on that object is its own line, and is not joined to the rest of the object. This happens when an object is created in AutoCAD using lines rather than polylines. This can easily be fixed by following the directions below:

    1. On the Modify menu, click Object -> Polyline.

    2. Select the polyline to modify.

    3. If the selected object is a line or an arc, AutoCAD prompts:

    Object selected is not a polyline. Do you want it to turn into one? : Enter y or n, or press ENTER.

    If you enter y, the object is converted into a single-segment 2D polyline that you can edit. You can use this operation to join lines and arcs into a polyline.

    When the PEDITACCEPT system variable is set to 1, this prompt is suppressed, and the selected object is automatically converted to a polyline.

    4. Edit the polyline by entering one or more of the following options:

    Enter j (Join) to join contiguous lines, arcs, or polylines.


Join Polylines in StyleCAD


StyleCAD now allows the user to do this within StyleCAD itself without having to go back into AutoCAD and running this procedure. This is useful when files have already been imported into StyleCAD, and the user does not want to re-import the files. In fact, StyleCAD's new method of joining polylines is more intuitive than AutoCAD's own method.

Step 1: Importing AutoCAD DXF

    1. Create a new style by selecting File -> New Style, then type in the new style name (use the DXF file name for simplicity), and finally click OK.

    2. Select File > Import External File -> Import DXF File to initiate the import process.

    3. Select the required DXF file and click the "Open" button.

    4. Select the correct DXF format and click the "OK" button.

    5. Select the correct layer (usually the OUT layer, but may be different) and click "OK".

    6. When the window asking "Process Internal Line detection?" appears, click Yes.

    7. When the detection has completed, the "Rearrange Patterns?" window appears. Answer NO (in case the lines were not joined in AutoCAD).

    8. Turn on the Fill option in the View Filter. If the shape is not colored (filled) , this means the lines are not joined.

    9. Move the disconnected lines as a complete object by holding down the space bar and dragging with the left mouse button. This will move the lines into the best working position.

    10. Zoom in and out as required.

    11. Continue to Step 2: Joining the Polylines below.


Step 2: Joining the Polylines

    1. First create a selction box around the shape whose lines you would like to convert into connected polylines.



    The selected points turn red.



    2. Then right-click on one of the points to bring up the pop-up menu, and select "Join Polylines".



    3. The polylines are joined, and consequently the shape becomes a temp pattern.



    4. Convert the temp pattern into a normal pattern by right clicking anywhere inside the temp pattern and selecting "Convert to Pattern". The pattern now becomes filled just like any other pattern.

Note: If a pattern has internal elements associated with it, such as drill holes, etc, and you wish to group those internal elements with the pattern, first make sure all polylines are formed so the shape is a pattern (make sure you have converted it from a temp pattern). Then simply drag a selection box around the entire pattern, and all of the points (including those belonging to the internal elements) will turn red. Then simply right-click on any internal element's point and select Group/Ungroup -> Group Polyline. All of the internal elements will now be grouped with the pattern.

Go Back